必要条件与安装

本页列出安装Tiki的最低必要条件

  如果你正在使用标准的共享主机,你可以假设已复合必要条件,Tiki就是被设计要运行在LAMP共享主机上的。对于要配置Tiki服务器的人来说下面的指示非常有用。

本页翻译已完成


Table of contents

必要条件

Web服务器

  Tiki是在Linux和Apache上面开发及广泛使用的。但是,Tiki应能运行在任何支持PHP的Web服务器上,像Windows/IIS、lighttpd等,但你需要做些调整。请看Windows兼容项目

你的Web服务器配置应达到一下最低要求:

数据库

  Tiki需要一个有效的关系数据库连接。数据库可以安装与Web服务器相同的主机上(localhost)。也可以是个远程数据库。Tiki使用MySQL。

PHP

Tiki 3 (及以后版本) 需要 PHP 5 附带 MySQLi 扩展
Tiki 4 (及以后版本) 用PHP 5 附带 PDO 扩展会更好。 如果没有PDO你可以倒退到ADOdb。 请看: ReleaseNotes40(发布说明)

PHP内存限制说明: 一些ISP安装的PHP将内存做了限制,memory_limit = 8m。这种情况下,Tiki可以安装,开始运行时看起来也正常,当有了负载,内存限制就会导致Tiki出现异常:页面装载不正常,出现古怪的问题等。要检查内存限制,用浏览器打开 域名.com/tiki-phpinfo.php 。在页面中搜索三个配置值:
  • max_execution_time = 60 ; 每个脚本最多可以执行多长时间,以秒钟计算
  • max_input_time = 60 ; 每个脚本最多可以用多少时间分析所请求的数据
  • memory_limit = 32M ; 每个脚本最多可以消耗多少内存
一般用户通常无处理法这些限制,你必须敬请你的服务商给你多点资源。在一个负载较重的共享服务器上意味着其他PHP用户也会被分配到更多资源。

更多信息

[+]

可选软件或库

某些Tiki功能特性需要以下额外的软件或库:

功能特性额外要求
图像处理,生成缩略图,生成动态图标,以及防止机器人/自动注册。使用 GD Library 1.5 (或更高版本) or ImageMagick。PHP 4.3+默认包含ImageMagick。
像GeoCMS (Geospastial Content Management System)那样管理、显示地图Mapserver 4.6+
重写Tiki默认的URL使用Apache Apache Clean URLs 创建更短的或定制URL。


History Source